Issue2568

classification
Title: test_threading intermittent failure
Type: behaviour Severity: normal
Components: Versions: Jython 2.7
Milestone: Jython 2.7.1
process
Status: pending Resolution: fixed
Dependencies: Superseder:
Assigned To: stefan.richthofer Nosy List: jamesmudd, stefan.richthofer
Priority: normal Keywords:

Created on 2017-03-13.20:39:19 by jamesmudd, last changed 2017-03-15.13:28:39 by stefan.richthofer.

Messages
msg11221 (view) Author: James Mudd (jamesmudd) Date: 2017-03-13.20:39:18
When running the regression tests on linux I have occasionally noticed failures of test_threading with the output:

     [exec] test test_threading failed -- Traceback (most recent call last):
     [exec]   File "/home/james/git/jython/dist/Lib/test/lock_tests.py", line 413, in test_timeout
     [exec]     self.assertTrue(dt >= 0.2, dt)
     [exec] AssertionError: 0.199999809265

It seems to be a issue of precision.
msg11222 (view) Author: James Mudd (jamesmudd) Date: 2017-03-13.20:45:48
I have a PR to fix this https://github.com/jythontools/jython/pull/64

It uses the same approach already used in this test to allow for timing inaccuracies.
msg11224 (view) Author: Stefan Richthofer (stefan.richthofer) Date: 2017-03-13.22:42:08
This looks safe for me to be merged. If there are no concerns I will merge it.
msg11231 (view) Author: Stefan Richthofer (stefan.richthofer) Date: 2017-03-15.13:28:39
Applied PR 64 as of https://hg.python.org/jython/rev/f06cf81336e0.
History
Date User Action Args
2017-03-15 13:28:39stefan.richthofersetstatus: open -> pending
title: test_threading occassional failure -> test_threading intermittent failure
type: behaviour
messages: + msg11231
priority: normal
assignee: stefan.richthofer
resolution: fixed
2017-03-13 22:42:08stefan.richthofersetnosy: + stefan.richthofer
messages: + msg11224
2017-03-13 20:45:48jamesmuddsetmessages: + msg11222
2017-03-13 20:39:19jamesmuddcreate