Title: Jython launcher failure (Windows error 14001)
Type: crash Severity: normal
Components: Versions: Jython 2.7
Milestone: Jython 2.7.2
Status: closed Resolution: fixed
Dependencies: Superseder: jython-Installer 2.7.1 error code 14001
View: 2620
Assigned To: Nosy List: jamesmudd, jeff.allen, schnaser
Priority: Keywords:

Created on 2017-07-18.07:33:28 by jeff.allen, last changed 2017-10-21.13:00:15 by jeff.allen.

msg11477 (view) Author: Jeff Allen (jeff.allen) Date: 2017-07-18.07:33:26
I'm not totally sure I understand the cause but this user observes a problem launching, incidental to his original issue:

I think this is related to Windows' attempt to ensure the latest version of any given DLL is in use. A search suggests it has come up in other contexts and is solvable using options on PyInstaller.
msg11505 (view) Author: Mike Schnaser (schnaser) Date: 2017-07-27.20:03:33
I get the same issue when attempting to use 2.7.1. 2.7.1b3 appears to work OK.
msg11506 (view) Author: Mike Schnaser (schnaser) Date: 2017-07-27.20:10:54
I suppose I could provide some actual detail, sorry for the double post. 

To be more specific, I get this issue when installing 2.7.1 from Maven:





msg11578 (view) Author: James Mudd (jamesmudd) Date: 2017-09-07.19:09:35
This seems like a duplicate of #2620 Which contains a fix
msg11628 (view) Author: Jeff Allen (jeff.allen) Date: 2017-10-21.13:00:14
Duplicated by #2620, which we may as well allow to supersede it.

I think this is fixed at (thanks James) and if not, please follow up in #2620.
Date User Action Args
2017-10-21 13:00:15jeff.allensetstatus: open -> closed
superseder: jython-Installer 2.7.1 error code 14001
resolution: fixed
messages: + msg11628
2017-09-07 19:09:36jamesmuddsetnosy: + jamesmudd
messages: + msg11578
2017-07-27 20:10:54schnasersetmessages: + msg11506
2017-07-27 20:03:34schnasersetnosy: + schnaser
messages: + msg11505
2017-07-18 07:33:28jeff.allencreate