Title: Virtualenv gets confused using paths with ~
Type: Severity: normal
Components: None Versions: Jython 2.7
Status: open Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: stuaxo
Priority: Keywords:

Created on 2017-11-06.01:14:24 by stuaxo, last changed 2017-11-06.01:14:24 by stuaxo.

msg11647 (view) Author: stu (stuaxo) Date: 2017-11-06.01:14:22
I installed virtualenv, using Jythons pip with a view to using virtualenvwrapper.

$ sudo /usr/local/jython-2.7.0/bin/pip install virtualenv

virtualenvwrappers "mkvirtualenv" didn't seem to work, so I tried creating the env in the ~/.virtualenvs directory, but that didn't work:

$ /usr/local/jython-2.7.0/bin/virtualenv ~/.virtualenvs/jython-2.7.0
Cannot find file /usr/local/jython-2.7.0/Include (bad symlink)
New jython executable in /home/stu/.virtualenvs/jython-2.7.0/bin/jython
ERROR: The executable /home/stu/.virtualenvs/jython-2.7.0/bin/jython is not functioning
ERROR: It thinks sys.prefix is u'/mnt/data/home/stu/.virtualenvs/jython-2.7.0' (should be u'/home/stu/.virtualenvs/jython-2.7.0')
ERROR: virtualenv is not compatible with this system or executable

However - changing to the ~/.virtualenvs directory first, worked:

$ /usr/local/jython-2.7.0/bin/virtualenv jython-2.7.0
Cannot find file /usr/local/jython-2.7.0/Include (bad symlink)
New jython executable in /mnt/data/home/stu/.virtualenvs/jython-2.7.0/bin/jython
Installing setuptools, pip, wheel...done.
Date User Action Args
2017-11-06 01:14:24stuaxocreate