Author gma
Recipients gma, pjenvey
Date 2011-04-12.21:43:22
SpamBayes Score 4.773959e-15
Marked as misclassified No
Message-id <>
In-reply-to <>
Thanks for looking at this.  Was I supposed to respond direct to you?

I tried what you suggested, and found the following behavior.

I can get the jython interpreter to come up in an emacs buffer, but it  
does not print the prompt ( >>> ).
It will evaluate expressions and print results (no prompt) if I type  
them in the buffer.

The normal emacs process of evaluating buffers or regions of buffers  
does not seem to work at all -- I tried your file creation test.
But I think it's just because the prompt is not printed in the buffer.  
If I hand-type the prompt in the buffer, then emacs seems to send  
commands to it.

I re-tried my tests using jython2.2.1, and it works fine. Fails on  
2.5.2 and the other 2.5.x versions as well.

Perhaps the -i switch is not interpreted correctly?

I poked around in jython.jar, versions 2.2.1 and 2.5.2 and found these  
lines in 2.5.2 which may be causing the problem with the emacs buffer.

  PySystemState systemState = Py.getSystemState();
        // Decide if stdin is interactive
        if (!opts.fixInteractive || opts.interactive) {
            opts.interactive =  
            if (!opts.interactive) {
                systemState.ps1 = systemState.ps2 = Py.EmptyString;

On Apr 10, 2011, at 3:26 PM, Philip Jenvey wrote:

> Philip Jenvey <> added the comment:
> If it's related to #1723 then I would think it's still actually  
> "responding", you're just not seeing it respond. Try verifying  
> whether it's responding or not, e.g. input code to write something  
> to a tempfile and see if it works
> ----------
> nosy: +pjenvey
> _______________________________________
> Jython tracker <>
> <>
> _______________________________________
Date User Action Args
2011-04-12 21:43:23gmasetrecipients: + gma
2011-04-12 21:43:22gmalinkissue1726 messages
2011-04-12 21:43:22gmacreate