Issue1260

classification
Title: Why is asyncore.py so different?
Type: Severity: normal
Components: Library Versions: 2.5.1, 2.5b1, 2.5b0
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: amak Nosy List: amak, billiejoex, nriley
Priority: Keywords:

Created on 2009-02-04.03:54:58 by billiejoex, last changed 2009-02-04.16:02:23 by amak.

Messages
msg4124 (view) Author: Giampaolo Rodola' (billiejoex) Date: 2009-02-04.03:54:56
Hi,
I took a quick look at how asyncore.py has been modified in respect to
the cPython 2.5 version and, if I'm reading the diff correctly, it seems
that:

- OOB data support has been removed
- loop()'s count parameter is gone
- dispatcher's _map attribute seems to get removed in add_channel()
method for no reason (see also issue 12265)
- when calling dispatcher.listen() the add_channel() method gets called
and this is wrong since it results in having a duplicated fd in the
socket map
- dispatcher_with_send class constructor have lost the "map" parameter

Why all these changes? Most of them seem unnecessary to me, if not wrong
at all.
Out of curiosity I've tried to use cPython2.5's asyncore.py with Jython
by running pyftpdlib test suite and it seems it works almost the same so
I don't get most of the decisions that have been taken.
msg4125 (view) Author: Nicholas Riley (nriley) Date: 2009-02-04.08:52:14
It's not been modified from the 2.5 version, it's been modified from the 
2.3 version.  There's only been one change since then (r4027).  We should 
at least be basing our changes on the 2.5 version... feel free to remerge 
the changes if needed and as long as they don't cause any regressions, 
someone can check it in.
msg4127 (view) Author: Alan Kennedy (amak) Date: 2009-02-04.14:16:37
Giampaolo, please will you stop logging the same bugs against asyncore?

I've said already that I'm looking at asyncore's problems; an increased
number of bugs for asyncore is *not* going to get higher priority
attention for asyncore or pyftpdlib-on-jython; it already has my highest
priority attention.

Before I can address asyncore properly, I have to do testing on multiple
platforms, e.g. freebsd, linux, etc, because of bugs like this one

http://bugs.jython.org/issue1064

Setting all this up takes time, and I'm not doing this as a day-job; I'm
doing it on my own (limited) spare time.

Logging bugs like this one is not going to speed things along or
contribute more information to the situation.

Please be patient.
msg4128 (view) Author: Giampaolo Rodola' (billiejoex) Date: 2009-02-04.14:34:52
I'm sorry, I thought that providing a summary of all potential
issues/changes affecting asyncore would have helped, since I haven't
seen them summarized elsewhere.
msg4134 (view) Author: Alan Kennedy (amak) Date: 2009-02-04.16:02:23
These comments all refer to the old version of the asyncore module; I
have checked in a new version at r6013.

Closing this bug as "out of date".
History
Date User Action Args
2009-02-04 16:02:23amaksetstatus: open -> closed
resolution: out of date
messages: + msg4134
2009-02-04 14:34:52billiejoexsetmessages: + msg4128
2009-02-04 14:16:37amaksetassignee: amak
messages: + msg4127
nosy: + amak
2009-02-04 08:52:16nrileysetnosy: + nriley
messages: + msg4125
2009-02-04 03:55:13billiejoexsetcomponents: + Library
versions: + 2.5b0, 2.5.1, 2.5b1
2009-02-04 03:54:58billiejoexcreate