Title: jython crashes when running a Jmol-based script
Type: crash Severity: normal
Components: Versions: 2.5.0
Status: closed Resolution: invalid
Dependencies: Superseder:
Assigned To: Nosy List: connolly, nriley
Priority: Keywords:

Created on 2009-07-30.21:26:28 by connolly, last changed 2009-07-30.21:41:09 by nriley.

File name Uploaded Description Edit Remove
,jython-crash connolly, 2009-07-30.21:26:28 trace of jython crash
msg4966 (view) Author: Dan Connolly (connolly) Date: 2009-07-30.21:26:28
I'm using jython to drive Jmol and it crashes with SIGSEGV. A trace is

I'm trying to prune it down to a simpler case, but I can't seem
to reproduce the problem any other way.

To reproduce my environment, here are the files:

Jmol.jar is from jmol 11.6.21, i.e.
3255e1ed8e152b87ca004ddc2e1f0c11  Jmol.jar

My code (i.e. and a few other modules) is in .revision 1178

The input file, 1A1M.xml.gz is

The script also reads from 1A1M.pdb, i.e.

298621766c09c38162ec461756124e0c  1A1M.pdb
cfeb781816003bb99256134f4e5588ea  1A1M.xml.gz
msg4967 (view) Author: Dan Connolly (connolly) Date: 2009-07-30.21:29:43
forgot some version info:

> java -version
java version "1.5.0_15"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_15-b04)
Java HotSpot(TM) 64-Bit Server VM (build 1.5.0_15-b04, mixed mode)

> uname -a
Linux norbert #1 SMP 2008/02/10 20:01:04 UTC
x86_64 x86_64 x86_64 GNU/Linux
msg4968 (view) Author: Nicholas Riley (nriley) Date: 2009-07-30.21:41:00
This appears to be a JVM bug; it worked for me when I tried it on Sun 
1.6.0_14 on 64-bit Linux (RHEL5).
Date User Action Args
2009-07-30 21:41:09nrileysetstatus: open -> closed
2009-07-30 21:41:00nrileysetresolution: invalid
messages: + msg4968
nosy: + nriley
2009-07-30 21:29:43connollysetmessages: + msg4967
2009-07-30 21:26:28connollycreate