Issue1791

classification
Title: Library documentation is from the future.
Type: Severity: normal
Components: Documentation Versions: Jython 2.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: juneau001 Nosy List: amak, fwierzbicki, jeff.allen, juneau001, zyasoft
Priority: Keywords:

Created on 2011-08-21.09:54:54 by amak, last changed 2014-05-10.05:44:21 by zyasoft.

Messages
msg6609 (view) Author: Alan Kennedy (amak) Date: 2011-08-21.09:54:54
One of the users pointed out (issues 1788) that the socket module documentation refers to 2.6 features that don't yet exist.

http://www.jython.org/docs/library/socket.html

Presumably this is not the 2.5 version of the documentation?
msg6612 (view) Author: Jeff Allen (jeff.allen) Date: 2011-08-24.20:42:40
Essentially the same issue reported as #1590 and #1650.
msg6614 (view) Author: Juneau001 (juneau001) Date: 2011-08-25.12:49:34
The Python 2.6 documentation has been used for the Jython 2.5.x docs since they are available in Sphinx format.  There are bits and pieces that still pertain to 2.6 and it is a matter of clean-up.  Thanks for the catch.
msg7749 (view) Author: Alan Kennedy (amak) Date: 2013-02-25.20:20:52
Josh, now that we're moving to 2.7, we need to be able to update these documents.

Where are they repo'ed?
msg7766 (view) Author: Juneau001 (juneau001) Date: 2013-02-25.21:56:45
The documentation is stored on Sourceforge.

http://sourceforge.net/projects/jythondocs/

Thanks, and let me know if you have any questions.
msg7767 (view) Author: Alan Kennedy (amak) Date: 2013-02-25.22:09:14
OK, so it's a HG repo on sourceforge. It would be nice if we could get it into the HG repo on python.org.

I notice that there is no changelog there.

http://jythondocs.hg.sourceforge.net/hgweb/jythondocs/jythondocs/log

Josh, Frank, should we be moving this to hg.python.org?

I suppose keeping it separate has the benefit of being able to give permissions to the docs without giving permissions to code repo?

Otherwise I can't think of a reason why they should be in separate repos.
msg7771 (view) Author: Juneau001 (juneau001) Date: 2013-02-25.22:26:35
Sounds good to me...I can move it to python.org if you like.  I moved the website there last week, so it makes sense to have it all in one place.

There is no change log because I have not make any changes to the docs, unfortunately, since they have been committed.

Thanks Alan
msg7772 (view) Author: Alan Kennedy (amak) Date: 2013-02-25.22:31:15
My primary intention for the docs is to add links to jython specific documentation. For example, on the doc page for the socket module, I'd add a link to the wiki page, which acts as a sort of "release notes" page for jython sockets.

http://wiki.python.org/jython/NewSocketModule
msg7783 (view) Author: Juneau001 (juneau001) Date: 2013-02-26.05:31:06
Adding links, where needed, sounds like a good idea.  It may make sense to start over with the 2.7 Python docs and modify accordingly, adding Jython-specific content and getting rid of that content that is specific to CPython.  Should be easy enough to apply the current 2.5 docset template to the CPython 2.7 docs and go from there.
msg7814 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-02-26.21:17:22
We should move this to hg.python.org - probably under hg.python.org/jython-docs/ and (sort of unrelated) I need to find out why Josh had trouble creating jython-website.
msg8365 (view) Author: Jim Baker (zyasoft) Date: 2014-05-10.05:44:21
Duplicate of #1590
History
Date User Action Args
2014-05-10 05:44:21zyasoftsetstatus: open -> closed
resolution: duplicate
messages: + msg8365
nosy: + zyasoft
2013-02-26 21:17:22fwierzbickisetmessages: + msg7814
2013-02-26 05:31:06juneau001setmessages: + msg7783
2013-02-25 22:31:16amaksetmessages: + msg7772
2013-02-25 22:26:35juneau001setmessages: + msg7771
2013-02-25 22:09:14amaksetmessages: + msg7767
2013-02-25 21:56:45juneau001setmessages: + msg7766
2013-02-25 20:20:52amaksetmessages: + msg7749
2013-02-25 19:23:34fwierzbickisetnosy: + fwierzbicki
2013-02-25 19:23:26fwierzbickisetversions: + Jython 2.5, - 2.5.2
2011-08-25 12:49:35juneau001setassignee: juneau001
messages: + msg6614
2011-08-24 20:42:40jeff.allensetnosy: + jeff.allen, juneau001
messages: + msg6612
2011-08-21 09:54:54amakcreate