Issue1885

classification
Title: os.chmod return 'OSError: [Errno 20000] Unknown error: 20000' on solaris 11
Type: behaviour Severity: major
Components: Library Versions: Jython 2.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: fwierzbicki Nosy List: Nsakala, Shilpi, eeiddne, fwierzbicki
Priority: Keywords:

Created on 2012-05-16.23:17:53 by Nsakala, last changed 2013-03-07.18:53:21 by eeiddne.

Messages
msg7097 (view) Author: Stephane (Nsakala) Date: 2012-05-16.23:17:53
!! Simple to repoduce

root@django:~# /opt/jython-2.5.3b1/bin/jython test.py
Traceback (most recent call last):
  File "test.py", line 5, in <module>
    os.chmod(path, mode)
OSError: [Errno 20000] Unknown error: 20000: '/root/test.out'
root@django:~# df -n /root
/                   : zfs
root@django:~# cat test.py
import os

path = '/root/test.out'
mode = 511
os.chmod(path, mode)

!! This bug cause problem when trying to install django (and other django-jython utility that use chmod)
msg7098 (view) Author: Stephane (Nsakala) Date: 2012-05-16.23:22:09
!! problem related when using django

# CLASSPATH=/root/javalib/mysql.jar /opt/jython-2.5.2/bin/jython manage.py startapp stor
Notice: Couldn't set permission bits on /root/hello/../hello/stor/models.py. You're probably using an uncommon filesystem setup. No problem.
Notice: Couldn't set permission bits on /root/hello/../hello/stor/views.py. You're probably using an uncommon filesystem setup. No problem.
Notice: Couldn't set permission bits on /root/hello/../hello/stor/__init__.py. You're probably using an uncommon filesystem setup. No problem.
Notice: Couldn't set permission bits on /root/hello/../hello/stor/tests.py. You're probably using an uncommon filesystem setup. No problem.
msg7099 (view) Author: Stephane (Nsakala) Date: 2012-05-17.09:25:23
!! Actualy the problem is the same on ufs filesystem
!! It seems that os.chmod do the job (succed to change permission) but
!! return an error

root@django:~# touch /test_ufs/test.out
root@django:~# ls -l /test_ufs/test.out
-rw-r--r--   1 root     root           0 May 17 03:51 /test_ufs/test.out
root@django:~# /opt/jython-2.5.3b1/bin/jython test.py
Traceback (most recent call last):
  File "test.py", line 5, in <module>
    os.chmod(path, mode)
OSError: [Errno 20000] Unknown error: 20000: '/test_ufs/test.out'
root@django:~# ls -l /test_ufs/test.out
-rwxrwxrwx   1 root     root           0 May 17 03:51 /test_ufs/test.out
root@django:~# df -n /test_ufs
/test_ufs           : ufs

!! OS version
root@django:~# uname -a
SunOS django 5.11 11.0 i86pc i386 i86pc
msg7102 (view) Author: Stephane (Nsakala) Date: 2012-05-17.10:24:07
!!! The problem is not there with the last code (hg clone then compile)

root@django:~/src/jython-dev# hg tip
changeset:   6658:9fd8c5122bb1
tag:         tip
user:        Frank Wierzbicki <fwierzbicki@gmail.com>
date:        Wed May 16 21:33:41 2012 -0700
summary:     Added tag v2.7.0a1 for changeset 4f5e3c12edc0

root@django:~/src/jython-dev# /root/src/jython-dev/dist/bin/jython /root/test.py
toto
msg7105 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2012-05-18.17:28:41
2.5.3b2 is on my todo list for this week or next - since you say this is fixed on trunk I'll close when I release it.
msg7671 (view) Author: Shilpi (Shilpi) Date: 2013-02-13.12:12:52
Hi,
We are getting  this error  OSError: [Errno 20000] Unknown error: 20000:
10_CXC_132_9107_R2C05/bin/OssUtils.py", line 439, in copyFirmwareFile
    shutil.copy2(os.path.join(params['SSH_EW_PATH'], file), self.firmwarePath)
  /10_CXC_132_9107_R2C05/bin/OssUtils.py", line 439, in copyFirmwareFile
    shutil.copy2(os.path.join(params['SSH_EW_PATH'], file), self.firmwarePath)
  File "/opt/python/jpython/Lib/shutil.py", line 97, in copy2
    copystat(src, dst)
  File "/opt/python/jpython/Lib/shutil.py", line 74, in copystat
    os.chmod(dst, mode)
OSError: [Errno 20000] Unknown error: 20000: 

We are currently using  jython 2.5.2.
In which version this issue is fixed.
msg7787 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-02-26.16:51:14
This is fixed in 2.5.3 (which is out) and will be fixed in 2.5.4 (there is a release candidate for 2.5.4 if you want to try it)
msg7909 (view) Author: Donal Duane (eeiddne) Date: 2013-03-07.18:09:18
Hi,

We have take build 2.5.4rc1 but we are still seeing the error described here.
Is issue1885 definitely included in 2.5.4? Worryingly, it is NOT listed the fix list for 1.5.3 OR 2.5.4.

Please get back to me as soon as possible, thanks.
msg7910 (view) Author: Donal Duane (eeiddne) Date: 2013-03-07.18:10:19
do you have a specific debug script that we could use to test this fix?
msg7911 (view) Author: Donal Duane (eeiddne) Date: 2013-03-07.18:16:49
Setting up FTP files
Setting up FTP files
Creating FTP placeholder files
Creating FTP placeholder files
CMD: chmod 0777 /var/opt/ericsson/nms_smo_srv/smo_file_store/Software/EXTREME/10_CXC_132_9107_R2C05/Log/STP132-A/config
CMD: chmod 0777 /var/opt/ericsson/nms_smo_srv/smo_file_store/Software/EXTREME/10_CXC_132_9107_R2C05/Log/STP132-A/config
file: v784b1-patch1-4.SBxtr
file: v784b1-patch1-4.SBxtr
Moving SSH Firmware to FTP area
Moving SSH Firmware to FTP area
ERROR: MAIN SYSTEM ERROR
ERROR: MAIN SYSTEM ERROR
FAILED: Message: [Errno 20000] Unknown error: 20000: '/var/opt/ericsson/nms_smo_srv/smo_file_store/Software/EXTREME/10_CXC_132_9107_R2C05/firmware/v784b1-patch1-4.SBxtr'
Error traceback:
Traceback (most recent call last):
  File "/var/opt/ericsson/nms_smo_srv/smo_file_store/Software/EXTREME/10_CXC_132_9107_R2C05/bin/main.py", line 486, in <module>
    mashost.copyFirmwareFile(LAN_SWITCH_PARAMS,file)
  File "/var/opt/ericsson/nms_smo_srv/smo_file_store/Software/EXTREME/10_CXC_132_9107_R2C05/bin/OssUtils.py", line 439, in copyFirmwareFile
    shutil.copy2(os.path.join(params['SSH_EW_PATH'], file), self.firmwarePath)
  File "/var/opt/ericsson/nms_smo_srv/smo_file_store/Software/EXTREME/10_CXC_132_9107_R2C05/bin/OssUtils.py", line 439, in copyFirmwareFile
    shutil.copy2(os.path.join(params['SSH_EW_PATH'], file), self.firmwarePath)
  File "/opt/python/jpython/Lib/shutil.py", line 97, in copy2
    copystat(src, dst)
  File "/opt/python/jpython/Lib/shutil.py", line 74, in copystat
    os.chmod(dst, mode)
OSError: [Errno 20000] Unknown error: 20000: '/var/opt/ericsson/nms_smo_srv/smo_file_store/Software/EXTREME/10_CXC_132_9107_R2C05/firmware/v784b1-patch1-4.SBxtr'
End of trace
End
End
Python script executed, returning: FAILED



jpython$ ./jython -V
Jython 2.5.4rc1
msg7912 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-03-07.18:30:00
Hi Donal Duane,

The original poster says that their particular problem is fixed so we closed this. If you are experiencing a similar problem, please open a new bug with a description of your platform, the version of Jython used, and a small python file that will reproduce it. This will help us get to the bottom of your issue.
msg7913 (view) Author: Donal Duane (eeiddne) Date: 2013-03-07.18:53:21
Hi Frank - will do. Just on the release note - is there any specific reason why 1885 is not listed as fixed?

Regards,
Dónal
History
Date User Action Args
2013-03-07 18:53:21eeiddnesetmessages: + msg7913
2013-03-07 18:30:37fwierzbickisetversions: + Jython 2.5, - 2.5.3b1
2013-03-07 18:30:00fwierzbickisetmessages: + msg7912
2013-03-07 18:16:49eeiddnesetmessages: + msg7911
2013-03-07 18:10:19eeiddnesetmessages: + msg7910
2013-03-07 18:09:18eeiddnesetnosy: + eeiddne
messages: + msg7909
2013-02-26 16:51:14fwierzbickisetmessages: + msg7787
2013-02-19 21:43:15fwierzbickisetstatus: open -> closed
resolution: fixed
2013-02-13 12:12:53Shilpisetnosy: + Shilpi
messages: + msg7671
2012-05-18 17:28:41fwierzbickisetassignee: fwierzbicki
messages: + msg7105
nosy: + fwierzbicki
2012-05-17 10:24:08Nsakalasetmessages: + msg7102
2012-05-17 09:25:24Nsakalasetmessages: + msg7099
title: os.chmod fail on solaris with zfs filesystem -> os.chmod return 'OSError: [Errno 20000] Unknown error: 20000' on solaris 11
2012-05-16 23:22:09Nsakalasetmessages: + msg7098
2012-05-16 23:17:53Nsakalacreate