Issue1893

classification
Title: easy_install fails with ImportError: No module named pkg_resources
Type: behaviour Severity: normal
Components: Library Versions: 2.7a1
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: fwierzbicki Nosy List: alex.gronholm, fwierzbicki, oscar
Priority: urgent Keywords:

Created on 2012-05-23.22:02:40 by oscar, last changed 2012-06-07.18:12:10 by fwierzbicki.

Messages
msg7134 (view) Author: Oscar (oscar) Date: 2012-05-23.22:02:39
When following the instructions from the Jython book re installing easy_install, easy_install fails to run.

$ sudo /usr/local/jython2.7a1/bin/easy_install
Traceback (most recent call last):
  File "/usr/local/jython2.7a1/bin/easy_install", line 5, in <module>
    from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
msg7135 (view) Author: Alex Grönholm (alex.gronholm) Date: 2012-05-23.23:43:14
This happens because the site-packages directory is not on sys.path. Why it is not there is a whole another matter.
msg7136 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2012-05-24.00:03:51
yes import is busted - I'll need to put out a 2.7a2 already - the issue is a dumb mistake on my part in site.py that is fixed on tip -- see http://bugs.jython.org/issue1892 for the details
msg7137 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2012-05-24.00:05:01
I'll leave this open until I get a 2.7a2 out
msg7145 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2012-05-25.05:39:56
OK I rolled another release - grab it at https://sourceforge.net/projects/jython/files/jython-dev/2.7.0a2/jython_installer-2.7a2.jar/download this is a soft launch so if no one spots any horrible bugs before tomorrow morning I'll write up a blog post about it.
msg7149 (view) Author: Oscar (oscar) Date: 2012-05-25.17:14:17
Pulling it now.

Thanks!

Sent from my iPad

On May 24, 2012, at 10:39 PM, Frank Wierzbicki <report@bugs.jython.org> wrote:

> 
> Frank Wierzbicki <fwierzbicki@users.sourceforge.net> added the comment:
> 
> OK I rolled another release - grab it at https://sourceforge.net/projects/jython/files/jython-dev/2.7.0a2/jython_installer-2.7a2.jar/download this is a soft launch so if no one spots any horrible bugs before tomorrow morning I'll write up a blog post about it.
> 
> _______________________________________
> Jython tracker <report@bugs.jython.org>
> <http://bugs.jython.org/issue1893>
> _______________________________________
msg7150 (view) Author: Oscar (oscar) Date: 2012-05-25.18:27:07
Looks like it' only got partial ssl support

False
>>> import socket
>>> hasattr(socket, 'ssl')
True

as a result 'pip install tornado' fails with URLError: <urlopen error unknown urltype: https>

I checked and 2.7a1 has the same issue but 2.5.3b1 works fine.

Sent from my iPad

On May 24, 2012, at 10:39 PM, Frank Wierzbicki <report@bugs.jython.org> wrote:

> 
> Frank Wierzbicki <fwierzbicki@users.sourceforge.net> added the comment:
> 
> OK I rolled another release - grab it at https://sourceforge.net/projects/jython/files/jython-dev/2.7.0a2/jython_installer-2.7a2.jar/download this is a soft launch so if no one spots any horrible bugs before tomorrow morning I'll write up a blog post about it.
> 
> _______________________________________
> Jython tracker <report@bugs.jython.org>
> <http://bugs.jython.org/issue1893>
> _______________________________________
msg7152 (view) Author: Oscar (oscar) Date: 2012-05-25.20:41:30
I filed 1897 re the ssl issue (and fixed the paste error which dropped half the content of the email)
History
Date User Action Args
2012-06-07 18:12:10fwierzbickisetstatus: open -> closed
2012-05-25 20:41:31oscarsetmessages: + msg7152
2012-05-25 18:27:07oscarsetmessages: + msg7150
2012-05-25 17:14:18oscarsetmessages: + msg7149
2012-05-25 05:39:56fwierzbickisetmessages: + msg7145
2012-05-24 00:05:01fwierzbickisetresolution: duplicate
messages: + msg7137
2012-05-24 00:03:52fwierzbickisetmessages: + msg7136
2012-05-23 23:43:14alex.gronholmsetpriority: urgent
assignee: fwierzbicki
messages: + msg7135
nosy: + alex.gronholm, fwierzbicki
2012-05-23 22:02:40oscarcreate