Issue1970

classification
Title: Minor issue in _syscmd_uname (platform.py)
Type: behaviour Severity: minor
Components: Library Versions: 2.7a2
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: amak Nosy List: amak, olefevre
Priority: Keywords:

Created on 2012-09-10.17:07:11 by olefevre, last changed 2013-02-16.13:38:02 by amak.

Messages
msg7458 (view) Author: Olivier Lefevre (olefevre) Date: 2012-09-10.17:07:11
On Windows the call to os.popen('uname %s 2> /dev/null' % option) will print a message saying the file (i.e., /dev/null) cannot be found, which pollutes the output. Ironically it is precisely to prevent such pollution when uname is not found that uname stderr is redirected to /dev/null.

The sys.platform check at the start of _syscmd_uname is useless as currently written because under jython sys.platform is 'javaxxx', which masks the "true" platform (or at least the relevant one for this operation).
msg7687 (view) Author: Alan Kennedy (amak) Date: 2013-02-16.13:38:02
Closing as a duplicate of 

http://bugs.jython.org/issue1899

Which was just fixed

2.5: http://hg.python.org/jython/rev/ce225289358a
tip: http://hg.python.org/jython/rev/d1cdccf5daa8
History
Date User Action Args
2013-02-16 13:38:02amaksetstatus: open -> closed
assignee: amak
resolution: duplicate
messages: + msg7687
nosy: + amak
2012-09-10 17:07:11olefevrecreate