Issue2025

classification
Title: issue1885 re-occuring on Jython 2.5.4
Type: behaviour Severity: critical
Components: Library Versions: Jython 2.5
process
Status: open Resolution: remind
Dependencies: Superseder:
Assigned To: Nosy List: davidoc, eeiddne, fwierzbicki
Priority: Keywords:

Created on 2013-03-07.19:00:48 by eeiddne, last changed 2014-06-19.04:43:39 by zyasoft.

Messages
msg7914 (view) Author: Donal Duane (eeiddne) Date: 2013-03-07.19:00:48
Hi,

Version Jython 2.5.4

./jython -V
Jython 2.5.4rc1


OS: Solaris 10 (x86)

uname -a
SunOS atrcxb1809 5.10 Generic_147441-19 i86pc i386 i86pc


We are experiencing the exact same issue that was reported in  http://bugs.jython.org/issue1885 even though we have upgraded from Jython 2.5.2 to Jython 2.5.4:


FAILED: Message: [Errno 20000] Unknown error: 20000: '/var/opt/ericsson/nms_smo_srv/smo_file_store/Software/EXTREME/10_CXC_132_9107_R2C05/firmware/v784b1-patch1-4.SBxtr'
Error traceback:
Traceback (most recent call last):
File "/var/opt/ericsson/nms_smo_srv/smo_file_store/Software/EXTREME/10_CXC_132_9107_R2C05/bin/main.py", line 486, in <module>
mashost.copyFirmwareFile(LAN_SWITCH_PARAMS,file)
File "/var/opt/ericsson/nms_smo_srv/smo_file_store/Software/EXTREME/10_CXC_132_9107_R2C05/bin/OssUtils.py", line 439, in copyFirmwareFile
shutil.copy2(os.path.join(params['SSH_EW_PATH'], file), self.firmwarePath)
File "/var/opt/ericsson/nms_smo_srv/smo_file_store/Software/EXTREME/10_CXC_132_9107_R2C05/bin/OssUtils.py", line 439, in copyFirmwareFile
shutil.copy2(os.path.join(params['SSH_EW_PATH'], file), self.firmwarePath)
File "/opt/python/jpython/Lib/shutil.py", line 97, in copy2
copystat(src, dst)
File "/opt/python/jpython/Lib/shutil.py", line 74, in copystat
os.chmod(dst, mode) 


I have done a checksum comparison between the 2.5.2 shutil.py and the 2.5.4 version - and they are identical - not sure if that is relevent, but just in case:

cksum /opt/python/jpython/Lib/shutil.py
633590336       6103    /opt/python/jpython/Lib/shutil.py

vs

cksum /opt/python/jpython/Lib/shutil.py
633590336       6103    /opt/python/jpython/Lib/shutil.py



thank you,

Regards,
Dónal
msg7915 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-03-07.19:15:32
What is the exact code that is failing?

Did this work on a previous version of Jython? Or did you get a different error message? What happens if you try the call from Jython as (something like):

os.system("chmod 0600 /path/to/file")
msg7916 (view) Author: Donal Duane (eeiddne) Date: 2013-03-07.19:17:53
the following (suggested by you) works:

from os import system
system('chmod 660 file.txt')
msg7917 (view) Author: Donal Duane (eeiddne) Date: 2013-03-07.19:19:31
We get the same error message on 2.5.2 and 2.5.4.
msg7918 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-03-07.19:20:39
Have you tried this on 2.7b1? The libraries we use to hit posix are more recent in 2.7 - they can't be upgraded as far in 2.5.4 because of dependencies that can't in turn be upgraded in the 2.5 series for backwards compatibility reasons.
msg7920 (view) Author: Donal Duane (eeiddne) Date: 2013-03-07.22:42:01
No -is 2.7b1 a stable release? Is it safe to deploy?

Regards 
Donal
msg7921 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-03-07.23:25:11
No 2.7b1 is a beta, so it is not ready for production. I'm just trying to see if the upgraded posix libraries solve your problem to give a clue as to what to do. Hopefully it won't be a really long time before 2.7 is final, but I don't have a concrete date yet.
msg7922 (view) Author: Donal Duane (eeiddne) Date: 2013-03-07.23:44:56
Hi frank -thanks. Is there any hope that we could back port the fix to 2.5.4?
msg7929 (view) Author: Donal Duane (eeiddne) Date: 2013-03-12.15:31:56
Hi Frank,

Just wondering you saw my below query?

Did you check if the posix libraries are fixed in 2.7? 

If so - Is there any way that we could port back the posix libraries from  2.7 to 2.5.4?

Regards,
Dónal
msg7930 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-03-12.15:57:28
Hi Donal,

I don't have access to a Solaris machine, so I can't actually check myself. 2.7b1 is available if you want to give it a try and let us know.
msg7931 (view) Author: Donal Duane (eeiddne) Date: 2013-03-12.16:06:11
Hi Frank,

Yes, we plan to try it - but if it DOES work - what about the liftback - is that supported?

You mentioned some issue with the new posix libraries and dependencies in 2.5.4?

Regards,
Dónal
msg7932 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-03-12.16:08:26
Ah I see - it sort of depends on why it works if it does. If it does turn out to be the jffi library updates, it probably can't be backported because the new jffi libs have dependencies that can't be backported. On the other hand, if it is broken in 2.7b1 or if it isn't the libraries that are the problem we might be able to find a back-portable solution.
msg7933 (view) Author: Donal Duane (eeiddne) Date: 2013-03-13.18:04:56
Hi Frank,

Bad (or good?) news - 2.7 does NOT fix the issue.
So - do you know what the fix for this is?

Maybe we should look @ fixing it locally?

Is the problem with the OS chmod, or, in the Jython code?

Regards,
Dónal
msg7934 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-03-15.17:08:41
Sorry for the slow response - I got the flu and just started to recover. Since this is almost certainly a bug in the posix library we use - the library authors are more closely associated with the JRuby project - I bet if you reproduce this on JRuby and log a bug with them you could get an expert to look into it. Another way to get their attention is to poke them  on irc on #jruby - they're very responsive there.
History
Date User Action Args
2014-06-19 04:43:39zyasoftsetresolution: remind
2013-04-17 10:55:34davidocsetnosy: + davidoc
2013-03-15 17:08:42fwierzbickisetmessages: + msg7934
2013-03-13 18:04:56eeiddnesetmessages: + msg7933
2013-03-12 16:08:26fwierzbickisetmessages: + msg7932
2013-03-12 16:06:11eeiddnesetmessages: + msg7931
2013-03-12 15:57:28fwierzbickisetmessages: + msg7930
2013-03-12 15:31:56eeiddnesetmessages: + msg7929
2013-03-07 23:44:56eeiddnesetmessages: + msg7922
2013-03-07 23:25:11fwierzbickisetmessages: + msg7921
2013-03-07 22:42:01eeiddnesetmessages: + msg7920
2013-03-07 19:20:39fwierzbickisetmessages: + msg7918
2013-03-07 19:19:31eeiddnesetmessages: + msg7917
2013-03-07 19:17:53eeiddnesetmessages: + msg7916
2013-03-07 19:15:32fwierzbickisetmessages: + msg7915
2013-03-07 19:10:48fwierzbickisetnosy: + fwierzbicki
2013-03-07 19:00:48eeiddnecreate