Issue2047

classification
Title: repr() failure on unpaired low surrogate
Type: behaviour Severity: normal
Components: Core Versions: Jython 2.7, Jython 2.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: amak Nosy List: Arfrever, amak, serhiy.storchaka
Priority: Keywords: patch

Created on 2013-05-11.22:01:11 by serhiy.storchaka, last changed 2013-05-28.02:10:10 by amak.

Files
File name Uploaded Description Edit Remove
unicode_escape_encode_last_surrogate.patch serhiy.storchaka, 2013-05-11.22:01:10
Messages
msg8010 (view) Author: Serhiy Storchaka (serhiy.storchaka) Date: 2013-05-11.22:01:10
$ jython -c "print repr(unichr(0xd800))"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
java.lang.StringIndexOutOfBoundsException: String index out of range: 1
        at java.lang.String.charAt(String.java:658)
        at org.python.core.PyString.encode_UnicodeEscape(PyString.java:164)
        at org.python.core.PyUnicode.unicode___repr__(PyUnicode.java:248)
        at org.python.core.PyUnicode.__repr__(PyUnicode.java:243)
        at org.python.core.__builtin__.repr(__builtin__.java:1078)
        at org.python.core.BuiltinFunctions.__call__(__builtin__.java:110)
        at org.python.core.PyObject.__call__(PyObject.java:401)
        at org.python.pycode._pyx0.f$0(<string>:1)
        at org.python.pycode._pyx0.call_function(<string>)
        at org.python.core.PyTableCode.call(PyTableCode.java:165)
        at org.python.core.PyCode.call(PyCode.java:18)
        at org.python.core.Py.runCode(Py.java:1204)
        at org.python.core.Py.exec(Py.java:1248)
        at org.python.util.PythonInterpreter.exec(PythonInterpreter.java:172)
        at org.python.util.jython.run(jython.java:279)
        at org.python.util.jython.main(jython.java:129)

java.lang.StringIndexOutOfBoundsException: java.lang.StringIndexOutOfBoundsException: String index out of range: 1

Here is a patch which fixes unicode-escape encoder used in unicode's repr().
msg8034 (view) Author: Alan Kennedy (amak) Date: 2013-05-28.02:10:10
Closing as a negative-image duplicate of http://bugs.jython.org/issue2048

All discussion will continue on #2048
History
Date User Action Args
2013-05-28 02:10:10amaksetstatus: open -> closed
assignee: amak
resolution: duplicate
messages: + msg8034
nosy: + amak
2013-05-20 09:45:41Arfreversetnosy: + Arfrever
2013-05-11 22:01:11serhiy.storchakacreate