Issue2144

classification
Title: Remove .idea artifacts from repo
Type: Severity: normal
Components: Versions: Jython 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: jeff.allen, santa4nt, zyasoft
Priority: Keywords: patch

Created on 2014-05-15.17:59:40 by santa4nt, last changed 2014-06-18.17:38:19 by zyasoft.

Files
File name Uploaded Description Edit Remove
remove_idea.diff santa4nt, 2014-05-15.17:59:39
unnamed zyasoft, 2014-05-15.22:25:30
Messages
msg8410 (view) Author: Santoso Wijaya (santa4nt) Date: 2014-05-15.17:59:39
The IntelliJ .idea files are not needed in the repository and are, in fact, defunct in some cases (dependencies missing, misconfigured, etc).

Since there is already a way to import the Eclipse configuration included in the repo as is, and have it work well with IDEA, these out-of-date files are maintenance liability and interferes with development if using IDEA.

See: https://wiki.python.org/jython/JythonDeveloperGuide/IntellijNotes
msg8411 (view) Author: Jeff Allen (jeff.allen) Date: 2014-05-15.22:18:16
Duplicate of #2113?

I think there's some merit in excluding IDE configuration (Eclipse too) from the repository. I find .classpath, for example, changes frequently and I've taken to excluding it from commits manually each time so as not to add spurious change. They also pick up paths specific to my workspace (such as where I keep source associated to external libraries).

On the other hand, though wrong, the Eclipse files did help me get started.
msg8412 (view) Author: Jim Baker (zyasoft) Date: 2014-05-15.22:25:31
Santoso, to summarize: we should .hgignore these artifacts?

On Thu, May 15, 2014 at 1:59 PM, Santoso Wijaya <report@bugs.jython.org>wrote:

>
> New submission from Santoso Wijaya:
>
> The IntelliJ .idea files are not needed in the repository and are, in
> fact, defunct in some cases (dependencies missing, misconfigured, etc).
>
> Since there is already a way to import the Eclipse configuration included
> in the repo as is, and have it work well with IDEA, these out-of-date files
> are maintenance liability and interferes with development if using IDEA.
>
> See: https://wiki.python.org/jython/JythonDeveloperGuide/IntellijNotes
>
> ----------
> files: remove_idea.diff
> keywords: patch
> messages: 8410
> nosy: santa4nt
> severity: normal
> status: open
> title: Remove .idea artifacts from repo
> versions: Jython 2.7
> Added file: http://bugs.jython.org/file1409/remove_idea.diff
>
> _______________________________________
> Jython tracker <report@bugs.jython.org>
> <http://bugs.jython.org/issue2144>
> _______________________________________
>
>
> ------------------------------------------------------------------------------
> "Accelerate Dev Cycles with Automated Cross-Browser Testing - For FREE
> Instantly run your Selenium tests across 300+ browser/OS combos.
> Get unparalleled scalability from the best Selenium testing platform
> available
> Simple to use. Nothing to install. Get started now for free."
> http://p.sf.net/sfu/SauceLabs
> _______________________________________________
> Jython-bugs mailing list
> Jython-bugs@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/jython-bugs
>
>
msg8414 (view) Author: Santoso Wijaya (santa4nt) Date: 2014-05-15.23:08:50
@Jim,

Yes, add them to .hgignore and remove them from a clean checkout of the repo, as well (since right now they're not fresh and to get IDEA set up you'd need to first delete the checked out files first, etc).
msg8418 (view) Author: Jim Baker (zyasoft) Date: 2014-05-16.14:00:29
Santoso, thanks. I'm user of IntelliJ, but definitely not a power user. (I otherwise use Emacs.) As a general principle, we want users who use IntelliJ or other editors/IDEs of their choice can set up Jython dev with minimal fuss.

Target beta 4.
msg8648 (view) Author: Jeff Allen (jeff.allen) Date: 2014-06-15.16:23:27
I'll do the same for Eclipse. I think it is useful for a new starter to have an IDE configuration works, but the Wiki is a better way to publish it, either as instructions or files.
msg8665 (view) Author: Jim Baker (zyasoft) Date: 2014-06-18.17:38:19
Fixed in a series of commits culminating in http://hg.python.org/jython/rev/ea302f9e4c3a
History
Date User Action Args
2014-06-18 17:38:19zyasoftsetstatus: open -> closed
resolution: fixed
messages: + msg8665
2014-06-15 16:23:28jeff.allensetmessages: + msg8648
2014-05-16 14:00:29zyasoftsetmessages: + msg8418
2014-05-15 23:08:51santa4ntsetmessages: + msg8414
2014-05-15 22:25:31zyasoftsetfiles: + unnamed
nosy: + zyasoft
messages: + msg8412
2014-05-15 22:18:16jeff.allensetnosy: + jeff.allen
messages: + msg8411
2014-05-15 17:59:40santa4ntcreate