Issue2585

classification
Title: test_ssl failure due to Netty exception mapping
Type: Severity: normal
Components: Versions:
Milestone: Jython 2.7.1
process
Status: pending Resolution: fixed
Dependencies: Superseder:
Assigned To: stefan.richthofer Nosy List: jamesmudd, stefan.richthofer
Priority: normal Keywords:

Created on 2017-05-04.18:15:20 by jamesmudd, last changed 2017-05-05.07:21:08 by jamesmudd.

Messages
msg11344 (view) Author: James Mudd (jamesmudd) Date: 2017-05-04.18:15:20
Running test_ssl as part of the regrtests or individually on linux I see the following failure:

FAIL: test_connect_ex_error (test_ssl.NetworkedTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/james/git/jython/Lib/test/test_ssl.py", line 1343, in test_connect_ex_error
    self.assertIn(rc, errors)
AssertionError: -1 not found in (111, 113, 110, 11)

I believe the cause is the handling of netty exceptions
msg11345 (view) Author: James Mudd (jamesmudd) Date: 2017-05-04.18:35:46
I have a pull request to fix this one https://github.com/jythontools/jython/pull/75

The patch I have submitted uses the same work around already present for another exception type. It seems like a better solution would be to look in the exception map for the type, then if not found it's super-type and so on. Then only fall through if there are no mapped exceptions, in the actual exceptions type hierarchy.  If this approach would be preferred I don't mind having a better look at this one. With this fixed I now have no test failures on linux.
msg11346 (view) Author: James Mudd (jamesmudd) Date: 2017-05-04.21:39:55
I also notice test_ssl is disabled on the Travis builds, not sure if its because of this problem or not but if it is we could re-enable it.
msg11349 (view) Author: Stefan Richthofer (stefan.richthofer) Date: 2017-05-04.22:56:07
James, I'm going to accept your PR. Confirmed it works well and find the solution okay for now.


>With this fixed I now have no test failures on linux.

I still see test_dumbdbm, test_mailbox and test_shutil fail.
Sure you don't observe any of these?
I wasn't aware these tests are uncommon failures; maybe I'll better open issues and share details...
msg11350 (view) Author: Stefan Richthofer (stefan.richthofer) Date: 2017-05-04.23:36:52
Merged https://github.com/jythontools/jython/pull/76 and https://github.com/jythontools/jython/pull/77 as of https://hg.python.org/jython/rev/7ad8eedaa14a.

Regarding
https://github.com/jythontools/jython/pull/76
I am still concerned because of test_dumbdbm, test_mailbox and test_shutil.
msg11352 (view) Author: James Mudd (jamesmudd) Date: 2017-05-05.07:21:07
@Stefan Thanks for merging those.

For me test_dumbdbm, test_mailbox and test_shutil all pass. This time I was running on Linux Mint x64 with test environment:
     [exec] == 2.7.1rc1 (, May 5 2017, 08:02:59) 
     [exec] == [OpenJDK 64-Bit Server VM (Oracle Corporation)]
     [exec] == platform: java1.8.0_121
     [exec] == encodings: stdin=UTF-8, stdout=UTF-8, FS=None
     [exec] == locale: default=('en_US', 'UTF-8'), actual=(None, None)

I have definitely seen them reliably pass with Oracle Java 8 as well I haven't run java 7 for a while. Some more details would be good I guess.
History
Date User Action Args
2017-05-05 07:21:08jamesmuddsetmessages: + msg11352
2017-05-04 23:36:52stefan.richthofersetstatus: open -> pending
resolution: accepted -> fixed
messages: + msg11350
title: test_ssl failure on linux -> test_ssl failure due to Netty exception mapping
2017-05-04 22:56:07stefan.richthofersetnosy: + stefan.richthofer
messages: + msg11349
priority: normal
assignee: stefan.richthofer
milestone: Jython 2.7.1
resolution: accepted
2017-05-04 21:39:56jamesmuddsetmessages: + msg11346
2017-05-04 18:35:47jamesmuddsetmessages: + msg11345
2017-05-04 18:15:20jamesmuddcreate