Issue2637

classification
Title: RobotFramework for Jython couldn't be installed in Mac
Type: behaviour Severity: normal
Components: Installer Versions: Jython 2.7
Milestone: Jython 2.7.1
process
Status: pending Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: Roja, jeff.allen
Priority: Keywords:

Created on 2017-10-29.16:33:19 by Roja, last changed 2017-10-30.07:30:50 by jeff.allen.

Messages
msg11635 (view) Author: (Roja) Date: 2017-10-29.16:33:18
Hi,

Im new to Mac OS X and trying to set up robot framework environment using eclipse. I have installed python with robot framework successfully. When installed, the robot framework is saved in the path /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages. Its my time to install Jython with Robotframework. I have installed Jython and tried to install Robot framework. Tried to execute the command ‘pip install robot framework’ in terminal. It ended up stating “Requirement already satisfied: robotframework in /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages”

This creates me problem in Java code execution which is integrated with Robot Framework. Please help me rectifying this situation.
msg11636 (view) Author: Jeff Allen (jeff.allen) Date: 2017-10-30.07:30:48
If pip finds the CPython installation, then almost certainly you have run the copy of pip that comes with CPython. I tried this myself and it seemed to install ok. Sorry, this is Windows PowerShell, but you'll be able to translate ...

PS issue2637> java -jar D:\InstKits\jython.org\jython-installer-2.7.1.jar

... here I specified it should install in .\inst, to keep it separate from any other Jythons.

Collecting setuptools
Collecting pip
Installing collected packages: setuptools, pip
Successfully installed pip-9.0.1 setuptools-28.8.0

PS issue2637> $env:PATH=".\inst\bin;"+$env:PATH
PS issue2637> $env:PATH
.\inst\bin;C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\; ...

... You can check which pip you get with:

PS issue2637> pip -V
pip 9.0.1 from C:\Users\Jeff\Documents\Jython\issue2637\inst\Lib\site-packages (python 2.7)

PS issue2637> pip install robotframework
Collecting robotframework
  Downloading robotframework-3.0.2.tar.gz (440kB)
    100% |████████████████████████████████| 450kB 435kB/s
Installing collected packages: robotframework
  Running setup.py install for robotframework ... done
Successfully installed robotframework-3.0.2

On Windows this leaves me with a jybot.bat in .\inst\bin which seems to be the Jython-specific launcher. I can at least run --help at this point, but didn't try any real work. No doubt it is slightly different on a Mac. I'm not sure how Eclipse connects to this, but it will clearly be important that it too finds the right installation of robot and invokes it with Jython, not CPython.

If that has answered it for you, I'll mark this as not a bug and close.
History
Date User Action Args
2017-10-30 07:30:50jeff.allensetstatus: open -> pending
nosy: + jeff.allen
messages: + msg11636
severity: urgent -> normal
2017-10-29 16:33:19Rojacreate